iMac 2011 with macOS Monterey

Don’t trash that iMac yet

The last OS officially supported by the iMac 2011 (iMac 12,1 – Mid2011) is macOS High Sierra. This is a problem for various reasons. The main reason being no recent application updates, for applications such as:

  • Microsoft Office 365
  • Microsoft OneDrive
  • Citrix Workspace
  • Apple XCode

Most manufacturers support only the last 3 versions of macOS for their applications. Macos High Sierra is version 10.13, the OS has been out of this 3 version cycle since Big Sur, the previous version of macOS.

There is however a community online which does their best to run more recent versions of macOS on unsupported machines. One of these projects resulted in OpenCore Legacy Patcher.

With this application it is easy to install macOS Monterey on the iMac 12.1. However there is one big caveat: The GPU (Radeon HD 6750M) is a non-metal supporting device. A solution would be to replace this GPU with a metal-capable GPU, but I do not want to invest €’s in a decade old piece of hardware. The project offers a ‘beta’ solution to support the card somewhat.

So with nothing to lose, I attempted this solution on my old iMac.

And it worked! But… I ran into the following issues:

  • There was flickering of the screen after installing the GPU-fix. To resolve this I had to use ResXtreme to change colours from billions to millions.
  • The menu bar on top was unreadable with a light background. I had to set the font to dark with this terminal command:
defaults write -g ASB_DarkMenuBar -bool true
Fix that font colour in the menu bar
  • I had to manually enter the wifi SSID & code in the wireless settings menu. Selecting the network from the list did nothing
  • The sliders for volume, brightness,… aren’t visible
  • The most recent version of Citrix Workspace just displays a white window. I was able to resolve this by rolling back to version 2108 for mac.
  • I can only connect my USB-headset after boot, otherwise the internal speakers of the iMac aren’t recognized.

I’ve installed Office, Unity (latest LTS), Blender, Visual Studio, Teams,… and all seem to be working. You can tell however that the 3D graphics aren’t as smooth as you would otherwise experience them. I believe they are running in a pseudo software mode. Youtubing and other media seems to go smoothly.

So yes, this is a way forward for a legacy machine. Great for a hobbyist, not something you would want to support in an enterprise environment, but those shouldn’t be running 10 year old hardware anyway 😉

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: